using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"('([0-9]*)': (\[[u'0-9, ]*])?)";
string input = @"{'27': [], '10864': [u'8344', u'7769', u'7207', u'3735']}";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}