$re = '/(\'([0-9]*)\': (\[[u\'0-9, ]*])?)/';
$str = '{\'27\': [], \'10864\': [u\'8344\', u\'7769\', u\'7207\', u\'3735\']}';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);