// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"('([0-9]*)': (\[[u'0-9, ]*])?)").unwrap();
let string = "{'27': [], '10864': [u'8344', u'7769', u'7207', u'3735']}";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}