import re
regex = re.compile(r"('([0-9]*)': (\[[u'0-9, ]*])?)")
test_str = "{'27': [], '10864': [u'8344', u'7769', u'7207', u'3735']}"
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")