re = /('([0-9]*)': (\[[u'0-9, ]*])?)/
str = '{\'27\': [], \'10864\': [u\'8344\', u\'7769\', u\'7207\', u\'3735\']}'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end