package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`('([0-9]*)': (\[[u'0-9, ]*])?)`)
var str = `{'27': [], '10864': [u'8344', u'7769', u'7207', u'3735']}`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}