using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\bhttps:\/\/|\.ingest\.sentry\.io\/)|.";
string substitution = @"$1*";
string input = @"https://87230a61de33450b964afbc0814884ec@p2238591.ingest.sentry.io/1504772008177343
https://.ingest.sentry.io/";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}