# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(\bhttps:\/\/|\.ingest\.sentry\.io\/)|."
test_str = ("https://87230a61de33450b964afbc0814884ec@p2238591.ingest.sentry.io/1504772008177343\n\n"
"https://.ingest.sentry.io/")
subst = "$1*"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.