const regex = /(\bhttps:\/\/|\.ingest\.sentry\.io\/)|./gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\bhttps:\\\/\\\/|\\.ingest\\.sentry\\.io\\\/)|.', 'gm')
const str = `https://87230a61de33450b964afbc0814884ec@p2238591.ingest.sentry.io/1504772008177343
https://.ingest.sentry.io/`;
const subst = `$1*`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);