// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(\bhttps:\/\/|\.ingest\.sentry\.io\/)|.").unwrap();
let string = "https://87230a61de33450b964afbc0814884ec@p2238591.ingest.sentry.io/1504772008177343
https://.ingest.sentry.io/";
let substitution = "$1*";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}