re = /(\bhttps:\/\/|\.ingest\.sentry\.io\/)|./m
str = 'https://87230a61de33450b964afbc0814884ec@p2238591.ingest.sentry.io/1504772008177343
https://.ingest.sentry.io/'
subst = '$1*'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result