#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(?<=^|\s)(?!goose(?:\s|$))\S+(?=\s|$)"
Local $sString = "ex!ended$w0rd goose random goose goose goose random random goose gooses1 test goose goose goose random222111 goose1 123123 asasdf asdf1v,! as$%dwerxxfs!"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)