import re
regex = re.compile(r"(?<=^|\s)(?!goose(?:\s|$))\S+(?=\s|$)", flags=re.MULTILINE)
test_str = "ex!ended$w0rd goose random goose goose goose random random goose gooses1 test goose goose goose random222111 goose1 123123 asasdf asdf1v,! as$%dwerxxfs!"
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)