$re = '/(?<=^|\s)(?!goose(?:\s|$))\S+(?=\s|$)/m';
$str = 'ex!ended$w0rd goose random goose goose goose random random goose gooses1 test goose goose goose random222111 goose1 123123 asasdf asdf1v,! as$%dwerxxfs!';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;