re = /(?<=^|\s)(?!goose(?:\s|$))\S+(?=\s|$)/m
str = 'ex!ended$w0rd goose random goose goose goose random random goose gooses1 test goose goose goose random222111 goose1 123123 asasdf asdf1v,! as$%dwerxxfs!'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result