import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=^|\\s)(?!goose(?:\\s|$))\\S+(?=\\s|$)";
final String string = "ex!ended$w0rd goose random goose goose goose random random goose gooses1 test goose goose goose random222111 goose1 123123 asasdf asdf1v,! as$%dwerxxfs!";
final String subst = "";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}