using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=^|\s)(?!goose(?:\s|$))\S+(?=\s|$)";
string substitution = @"";
string input = @"ex!ended$w0rd goose random goose goose goose random random goose gooses1 test goose goose goose random222111 goose1 123123 asasdf asdf1v,! as$%dwerxxfs!";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}