#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?i)((rhsoft|reindl|phpbugreports|bugreports)\d*@gmail)"
Local $sString = "rhsoft@gmail" & @CRLF & _
"rhsoft123@gmail" & @CRLF & _
"bugreports@gmail" & @CRLF & _
"bugreports123@gmail"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")