using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"((rhsoft|reindl|phpbugreports|bugreports)\d*@gmail)";
string input = @"rhsoft@gmail
rhsoft123@gmail
bugreports@gmail
bugreports123@gmail";
RegexOptions options = RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}