import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "((rhsoft|reindl|phpbugreports|bugreports)\\d*@gmail)";
final String string = "rhsoft@gmail\n"
+ "rhsoft123@gmail\n"
+ "bugreports@gmail\n"
+ "bugreports123@gmail";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}