$re = '/((rhsoft|reindl|phpbugreports|bugreports)\d*@gmail)/i';
$str = 'rhsoft@gmail
rhsoft123@gmail
bugreports@gmail
bugreports123@gmail';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);