re = /((rhsoft|reindl|phpbugreports|bugreports)\d*@gmail)/i
str = 'rhsoft@gmail
rhsoft123@gmail
bugreports@gmail
bugreports123@gmail'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end