// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?i)((rhsoft|reindl|phpbugreports|bugreports)\d*@gmail)").unwrap();
let string = "rhsoft@gmail
rhsoft123@gmail
bugreports@gmail
bugreports123@gmail";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}