# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/<span class="CharOverride-7">(.*)<\\/span>/$1/gU;t' <<< "<p class=\"2\"><span class=\"CharOverride-7\">A book title</span><a href=\"https://aaa.net\"><span class=\"CharOverride-8\">https://aaa.net</span></a><span class=\"CharOverride-7\">.</span></p>
<p class=\"2\"><span class=\"CharOverride-7\">Another book title</span><a href=\"https://aaa.net\"><span class=\"CharOverride-8\">https://aaa.net/</span></a><span class=\"CharOverride-7\">.</span></p>
"