const regex = /<span class="CharOverride-7">(.*)<\/span>/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<span class="CharOverride-7">(.*)<\\\/span>', 'g')
const str = `<p class="2"><span class="CharOverride-7">A book title</span><a href="https://aaa.net"><span class="CharOverride-8">https://aaa.net</span></a><span class="CharOverride-7">.</span></p>
<p class="2"><span class="CharOverride-7">Another book title</span><a href="https://aaa.net"><span class="CharOverride-8">https://aaa.net/</span></a><span class="CharOverride-7">.</span></p>
`;
const subst = `$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);