import re
regex = re.compile(r"<span class=\"CharOverride-7\">(.*)<\/span>")
test_str = ("<p class=\"2\"><span class=\"CharOverride-7\">A book title</span><a href=\"https://aaa.net\"><span class=\"CharOverride-8\">https://aaa.net</span></a><span class=\"CharOverride-7\">.</span></p>\n\n"
" <p class=\"2\"><span class=\"CharOverride-7\">Another book title</span><a href=\"https://aaa.net\"><span class=\"CharOverride-8\">https://aaa.net/</span></a><span class=\"CharOverride-7\">.</span></p>\n")
subst = "$1"
result = regex.sub(subst, test_str)
if result:
print(result)