using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<span class=""CharOverride-7"">(.*)<\/span>";
string substitution = @"$1";
string input = @"<p class=""2""><span class=""CharOverride-7"">A book title</span><a href=""https://aaa.net""><span class=""CharOverride-8"">https://aaa.net</span></a><span class=""CharOverride-7"">.</span></p>
<p class=""2""><span class=""CharOverride-7"">Another book title</span><a href=""https://aaa.net""><span class=""CharOverride-8"">https://aaa.net/</span></a><span class=""CharOverride-7"">.</span></p>
";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}