// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?U)<span class="CharOverride-7">(.*)<\/span>"#).unwrap();
let string = "<p class=\"2\"><span class=\"CharOverride-7\">A book title</span><a href=\"https://aaa.net\"><span class=\"CharOverride-8\">https://aaa.net</span></a><span class=\"CharOverride-7\">.</span></p>
<p class=\"2\"><span class=\"CharOverride-7\">Another book title</span><a href=\"https://aaa.net\"><span class=\"CharOverride-8\">https://aaa.net/</span></a><span class=\"CharOverride-7\">.</span></p>
";
let substitution = "$1";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}