import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "process\\s+(\\w+|\\\"[^\\\"]+\\\"|'[^']+')\\s*\\{((.|\\n|\\r)*)\\}";
final String string = "nextflow.enable.dsl=2\n\n"
+ "// params.module_dir = '.'\n"
+ "params.dbs_dir = '/mnt/OmicNAS/dd/alphafold/dbs'\n"
+ "params.max_template_date = '2020-05-14'\n"
+ "params.db_preset = 'reduced_dbs'\n"
+ "params.model_preset = 'monomer'\n"
+ "params.outdir = './'\n"
+ "params.cachedir = '/mnt/OmicNAS/cache/alphafold'\n\n"
+ "process ALPHAFOLD {\n"
+ " conda \"${moduleDir}/environment.yml\"\n\n"
+ " echo true\n\n"
+ " maxForks 1\n\n"
+ " stageInMode 'copy'\n\n"
+ " storeDir \"${params.cachedir}\"\n\n"
+ " publishDir \"${params.outdir}\", mode: 'copy'\n\n"
+ " input:\n"
+ " path fasta\n\n"
+ " output:\n"
+ " path \"*\", emit: outputs\n\n"
+ " script:\n"
+ " \"\"\"\n"
+ " python3 ${moduleDir}/docker/run_docker.py \\\n"
+ " --fasta_paths=${fasta} \\\n"
+ " --max_template_date=${params.max_template_date} \\\n"
+ " --model_preset=${params.model_preset} \\\n"
+ " --db_preset=${params.db_preset} \\\n"
+ " --data_dir=${params.dbs_dir} \\\n"
+ " --output_dir=\\$PWD\n"
+ " \"\"\"\n"
+ "}\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}