using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^X(?!(?:[^-\n]*-){2})(?=.*\p{Lu})[\p{Lu}\d-]{3,6}$";
string input = @"XABC
XA-BC8D
X-ABC
XB72D-
X123
XAB
XABC-123
XA--BC";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}