import re
regex = re.compile(r"^X(?!(?:[^-\n]*-){2})(?=.*\p{Lu})[\p{Lu}\d-]{3,6}$", flags=re.MULTILINE)
test_str = ("XABC\n"
"XA-BC8D\n"
"X-ABC\n"
"XB72D-\n\n"
"X123\n"
"XAB\n"
"XABC-123\n"
"XA--BC")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")