$re = '/^X(?!(?:[^-\n]*-){2})(?=.*\p{Lu})[\p{Lu}\d-]{3,6}$/m';
$str = 'XABC
XA-BC8D
X-ABC
XB72D-
X123
XAB
XABC-123
XA--BC';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);