use strict;
my $str = 'XABC
XA-BC8D
X-ABC
XB72D-
X123
XAB
XABC-123
XA--BC';
my $regex = qr/^X(?!(?:[^-\n]*-){2})(?=.*\p{Lu})[\p{Lu}\d-]{3,6}$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}