const regex = /^X(?!(?:[^-\n]*-){2})(?=.*\p{Lu})[\p{Lu}\d-]{3,6}$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^X(?!(?:[^-\\n]*-){2})(?=.*\\p{Lu})[\\p{Lu}\\d-]{3,6}$', 'gm')
const str = `XABC
XA-BC8D
X-ABC
XB72D-
X123
XAB
XABC-123
XA--BC`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}