import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^X(?!(?:[^-\\n]*-){2})(?=.*\\p{Lu})[\\p{Lu}\\d-]{3,6}$";
final String string = "XABC\n"
+ "XA-BC8D\n"
+ "X-ABC\n"
+ "XB72D-\n\n"
+ "X123\n"
+ "XAB\n"
+ "XABC-123\n"
+ "XA--BC";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}