#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "eventtype=\K\S+"
Local $sString = "(STUNNEL-SECURITY AND NOT (" & @CRLF & _
" eventtype=sec-stunnel-client-* " & @CRLF & _
" OR eventtype=sec-stunnel-crl-* " & @CRLF & _
" OR eventtype=sec-stunnel-loaded-* " & @CRLF & _
" OR eventtype=sec-stunnel-loading-* " & @CRLF & _
" OR eventtype=sec-stunnel-no-* " & @CRLF & _
" OR eventtype=sec-stunnel-openssl-* " & @CRLF & _
" OR eventtype=sec-stunnel-sconnect-* " & @CRLF & _
" OR eventtype=sec-stunnel-server-* " & @CRLF & _
" OR eventtype=sec-stunnel-service-* " & @CRLF & _
" OR eventtype=sec-stunnel-session-* " & @CRLF & _
" OR eventtype=sec-stunnel-socket-* " & @CRLF & _
" OR eventtype=sec-stunnel-ssl-* " & @CRLF & _
" OR eventtype=sec-stunnel-stats-* " & @CRLF & _
" OR eventtype=sec-stunnel-threading-* " & @CRLF & _
" OR eventtype=sec-stunnel-timeout-* " & @CRLF & _
" OR eventtype=sec-stunnel-various-* " & @CRLF & _
") )"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")