import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "eventtype=\\K\\S+";
final String string = "(STUNNEL-SECURITY AND NOT (\n"
+ " eventtype=sec-stunnel-client-* \n"
+ " OR eventtype=sec-stunnel-crl-* \n"
+ " OR eventtype=sec-stunnel-loaded-* \n"
+ " OR eventtype=sec-stunnel-loading-* \n"
+ " OR eventtype=sec-stunnel-no-* \n"
+ " OR eventtype=sec-stunnel-openssl-* \n"
+ " OR eventtype=sec-stunnel-sconnect-* \n"
+ " OR eventtype=sec-stunnel-server-* \n"
+ " OR eventtype=sec-stunnel-service-* \n"
+ " OR eventtype=sec-stunnel-session-* \n"
+ " OR eventtype=sec-stunnel-socket-* \n"
+ " OR eventtype=sec-stunnel-ssl-* \n"
+ " OR eventtype=sec-stunnel-stats-* \n"
+ " OR eventtype=sec-stunnel-threading-* \n"
+ " OR eventtype=sec-stunnel-timeout-* \n"
+ " OR eventtype=sec-stunnel-various-* \n"
+ ") )";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}