const regex = /eventtype=\K\S+/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('eventtype=\\K\\S+', 'g')
const str = `(STUNNEL-SECURITY AND NOT (
eventtype=sec-stunnel-client-*
OR eventtype=sec-stunnel-crl-*
OR eventtype=sec-stunnel-loaded-*
OR eventtype=sec-stunnel-loading-*
OR eventtype=sec-stunnel-no-*
OR eventtype=sec-stunnel-openssl-*
OR eventtype=sec-stunnel-sconnect-*
OR eventtype=sec-stunnel-server-*
OR eventtype=sec-stunnel-service-*
OR eventtype=sec-stunnel-session-*
OR eventtype=sec-stunnel-socket-*
OR eventtype=sec-stunnel-ssl-*
OR eventtype=sec-stunnel-stats-*
OR eventtype=sec-stunnel-threading-*
OR eventtype=sec-stunnel-timeout-*
OR eventtype=sec-stunnel-various-*
) )`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}