import re
regex = re.compile(r"eventtype=\K\S+")
test_str = ("(STUNNEL-SECURITY AND NOT (\n"
" eventtype=sec-stunnel-client-* \n"
" OR eventtype=sec-stunnel-crl-* \n"
" OR eventtype=sec-stunnel-loaded-* \n"
" OR eventtype=sec-stunnel-loading-* \n"
" OR eventtype=sec-stunnel-no-* \n"
" OR eventtype=sec-stunnel-openssl-* \n"
" OR eventtype=sec-stunnel-sconnect-* \n"
" OR eventtype=sec-stunnel-server-* \n"
" OR eventtype=sec-stunnel-service-* \n"
" OR eventtype=sec-stunnel-session-* \n"
" OR eventtype=sec-stunnel-socket-* \n"
" OR eventtype=sec-stunnel-ssl-* \n"
" OR eventtype=sec-stunnel-stats-* \n"
" OR eventtype=sec-stunnel-threading-* \n"
" OR eventtype=sec-stunnel-timeout-* \n"
" OR eventtype=sec-stunnel-various-* \n"
") )")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")