using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"eventtype=\K\S+";
string input = @"(STUNNEL-SECURITY AND NOT (
eventtype=sec-stunnel-client-*
OR eventtype=sec-stunnel-crl-*
OR eventtype=sec-stunnel-loaded-*
OR eventtype=sec-stunnel-loading-*
OR eventtype=sec-stunnel-no-*
OR eventtype=sec-stunnel-openssl-*
OR eventtype=sec-stunnel-sconnect-*
OR eventtype=sec-stunnel-server-*
OR eventtype=sec-stunnel-service-*
OR eventtype=sec-stunnel-session-*
OR eventtype=sec-stunnel-socket-*
OR eventtype=sec-stunnel-ssl-*
OR eventtype=sec-stunnel-stats-*
OR eventtype=sec-stunnel-threading-*
OR eventtype=sec-stunnel-timeout-*
OR eventtype=sec-stunnel-various-*
) )";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}