const regex = /\{"acks":"(\d+)"\}/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\{"acks":"(\\d+)"\\}', 'gm')
const str = `[{"acks":"6"},{"acks":"7"},{"acks":"8"}]`;
const subst = `$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);