use strict;
my $str = '[{"acks":"6"},{"acks":"7"},{"acks":"8"}]';
my $regex = qr/\{"acks":"(\d+)"\}/mp;
my $subst = '$1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";