$re = '/\{"acks":"(\d+)"\}/m';
$str = '[{"acks":"6"},{"acks":"7"},{"acks":"8"}]';
$subst = "$1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;