use strict;
my $str = 'aaaa68acl2s4fwdds#$s
41bssss2s3s4s2d3rffd
41bssss2s3s4s2d53rff';
my $regex = qr/^(.*?)\d\d[a-z](.*?)(?:\d\d[a-z](.*))?(?:\d\d[a-z](.*))?(?:\d\d[a-z](.*))?$/mp;
my $subst = '\\1\\2\\3\\4\\5';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";