# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^(.*?)\d\d[a-z](.*?)(?:\d\d[a-z](.*))?(?:\d\d[a-z](.*))?(?:\d\d[a-z](.*))?$"
test_str = ("aaaa68acl2s4fwdds#$s\n"
"41bssss2s3s4s2d3rffd\n"
"41bssss2s3s4s2d53rff")
subst = "\\1\\2\\3\\4\\5"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.