#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?=.*insert)(?=.*name).+"
Local $sString = "I would like to test if a string contains insert and name, with any interceding characters. And if it does, I would like to print the match. " & @CRLF & _
"this line not" & @CRLF & _
"this insert neither" & @CRLF & _
"neither name" & @CRLF & _
"but insert and name !"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")