re = /(?=.*insert)(?=.*name).+/
str = 'I would like to test if a string contains insert and name, with any interceding characters. And if it does, I would like to print the match.
this line not
this insert neither
neither name
but insert and name !'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end