using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?=.*insert)(?=.*name).+";
string input = @"I would like to test if a string contains insert and name, with any interceding characters. And if it does, I would like to print the match.
this line not
this insert neither
neither name
but insert and name !";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}