use strict;
my $str = 'I would like to test if a string contains insert and name, with any interceding characters. And if it does, I would like to print the match.
this line not
this insert neither
neither name
but insert and name !';
my $regex = qr~(?=.*insert)(?=.*name).+~p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}