import Foundation
let pattern = #"(?=.*insert)(?=.*name).+"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
I would like to test if a string contains insert and name, with any interceding characters. And if it does, I would like to print the match.
this line not
this insert neither
neither name
but insert and name !
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)